Apache HTTP 服务器 2.4.57 现已可用

Apache 软件基金会和 Apache HTTP 服务器项目宣布发布 Apache HTTP 服务器 2.4.57 版。

Apache 软件基金会和 Apache HTTP 服务器项目宣布推出最新版本的 Apache HTTP 服务器 2.4.57。 最新版本带来了一些错误修复,这对于确保尽可能长的正常运行时间至关重要。

几个变化

此版本的 Apache 是 Apache HTTPD 的新一代 2.4.x 分支的最新 GA 版本,推荐用于所有以前的版本。 Apache 基金会鼓励所有先前版本的 Apache HTTP Server 的用户升级到 2.4.57 版。

Apache HTTP Server 2.4.57 提供错误修复和对 mod_proxy、mod_http2、mod_rewrtite 和 mod_mime 模块的改进。 以下是所有更改:

mod_proxy:转发前检查一个nocanon路径在处理过程中没有被空格重写。
mod_proxy:如果 AllowEncodedSlashes 设置为 NoDecode,则不要对反向代理发送到后端的 URL 中的编码斜杠进行双重编码。
mod_http2:修复了连接终止期间的崩溃。
mod_rewrite:修复以问号结尾的替换的 2.4.56 回归。
mod_rewrite:添加“BCTLS”和“BNE”RewriteRule 标志。 在没有“NE”标志的情况下重新允许重定向的编码字符。
mod_proxy:当使用 mapping=encoded|servlet 时,修复转发到源服务器的请求的 uri 路径的双重编码。
mod_mime:如果 ProxyPass 与 nocanon 选项一起使用,请不要将扩展名与可能的查询字符串参数相匹配。

您可以通过以下链接下载 Apache HTTP Server 2.4.57:

点击此处下载 Apache HTTP Server 2.4.57

Apache HTTP Server 2.4.57 需要 Apache Portable Runtime (APR),最低版本 1.5.x 和 APR-Util,最低版本 1.5.x。 某些功能可能需要 1.6.x 版本的 APR 和 APR-Util。 必须升级 APR 库才能使 httpd 的所有功能正常运行。

升级或安装此版本的 Apache 时,请记住,如果您打算将 Apache 与线程 MPM 之一(Prefork MPM 除外)一起使用,则必须确保您将使用的任何模块(以及它们所依赖的库) on) 是线程安全的。

请注意 2.2.x 分支现在已经结束了 Apache HTTP Server 项目的生命周期,并且不会发生进一步的活动,包括安全补丁。 用户必须及时完成向 httpd 的这个 2.4.x 版本的转换,以便从进一步的错误修复或新功能中受益。

原创文章,作者:主机说,如若转载,请注明出处:https://www.hostingtalk.cn/apache-http-server-2-4-57-is-now-available/

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注

error: 内容保护